Apache HTTP Server: Multiple vulnerabilities — GLSA 201206-25

Multiple vulnerabilities were found in Apache HTTP Server.

Affected Packages

www-servers/apache on all architectures
Affected versions < 2.2.22-r1
Unaffected versions >= 2.2.22-r1

Background

Apache HTTP Server is one of the most popular web servers on the Internet.

Description

Multiple vulnerabilities have been discovered in Apache HTTP Server. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker might obtain sensitive information, gain privileges, send requests to unintended servers behind proxies, bypass certain security restrictions, obtain the values of HTTPOnly cookies, or cause a Denial of Service in various ways.

A local attacker could gain escalated privileges.

Workaround

There is no known workaround at this time.

Resolution

All Apache HTTP Server users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/apache-2.2.22-r1"
 

References

Release Date
June 24, 2012

Latest Revision
June 24, 2012: 1

Severity
high

Exploitable
local, remote

Bugzilla entries