Keepalived: Denial of Service — GLSA 201207-07

Keepalived uses world-writable PID files, allowing a local attacker to kill arbitrary processes.

Affected Packages

sys-cluster/keepalived on all architectures
Affected versions < 1.2.2-r3
Unaffected versions >= 1.2.2-r3

Background

Keepalived is a strong & robust keepalive facility to the Linux Virtual Server project.

Description

The "pidfile_write()" function in pidfile.c in Keepalived writes PID files with insecure permissions.

Impact

A local attacker may be able to cause a Denial of Service of arbitrary processes.

Workaround

There is no known workaround at this time.

Resolution

All Keepalived users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-cluster/keepalived-1.2.2-r3"
 

References

Release Date
July 09, 2012

Latest Revision
July 09, 2012: 1

Severity
normal

Exploitable
local

Bugzilla entries