Atheme IRC Services: Denial of Service — GLSA 201209-09

A vulnerability has been found in Atheme which may lead to Denial of Service or a bypass of security restrictions.

Affected Packages

net-irc/atheme-services on all architectures
Affected versions < 6.0.10
Unaffected versions >= 6.0.10

Background

Atheme is a portable and secure set of open-source and modular IRC services. CertFP is certificate fingerprinting used to authenticate users to nicknames.

Description

The “myuser_delete()” function in account.c does not properly remove CertFP entries when deleting user accounts.

Impact

A remote authenticated attacker may be able to cause a Denial of Service condition or gain access to an Atheme IRC Services user account.

Workaround

There is no known workaround at this time.

Resolution

All Atheme users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-irc/atheme-services-6.0.10"
 

References

Release Date
September 25, 2012

Latest Revision
September 25, 2012: 1

Severity
normal

Exploitable
remote

Bugzilla entries