fastjar: Directory traversal — GLSA 201209-21

Two directory traversal vulnerabilities have been found in fastjar, allowing remote attackers to create or overwrite arbitrary files.

Affected Packages

app-arch/fastjar on all architectures
Affected versions < 0.98-r1
Unaffected versions >= 0.98-r1

Background

fastjar is a Java archiver written in C.

Description

Two directory traversal vulnerabilities have been discovered in fastjar. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted JAR file, possibly resulting in the creation or truncation of arbitrary files.

Workaround

There is no known workaround at this time.

Resolution

All fastjar users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-arch/fastjar-0.98-r1"
 

References

Release Date
September 28, 2012

Latest Revision
September 28, 2012: 1

Severity
normal

Exploitable
remote

Bugzilla entries