VMware Player, Server, Workstation: Multiple vulnerabilities — GLSA 201209-25

Multiple vulnerabilities have been found in VMware Player, Server, and Workstation, allowing remote and local attackers to conduct several attacks, including privilege escalation, remote execution of arbitrary code, and a Denial of Service.

Affected Packages

app-emulation/vmware-player on all architectures
Affected versions <= 2.5.5.328052
Unaffected versions
app-emulation/vmware-workstation on all architectures
Affected versions <= 6.5.5.328052
Unaffected versions
app-emulation/vmware-server on all architectures
Affected versions <= 1.0.9.156507
Unaffected versions

Background

VMware Player, Server, and Workstation allow emulation of a complete PC on a PC without the usual performance overhead of most emulators.

Description

Multiple vulnerabilities have been discovered in VMware Player, Server, and Workstation. Please review the CVE identifiers referenced below for details.

Impact

Local users may be able to gain escalated privileges, cause a Denial of Service, or gain sensitive information.

A remote attacker could entice a user to open a specially crafted file, possibly resulting in the remote execution of arbitrary code, or a Denial of Service. Remote attackers also may be able to spoof DNS traffic, read arbitrary files, or inject arbitrary web script to the VMware Server Console.

Furthermore, guest OS users may be able to execute arbitrary code on the host OS, gain escalated privileges on the guest OS, or cause a Denial of Service (crash the host OS).

Workaround

There is no known workaround at this time.

Resolution

Gentoo discontinued support for VMware Player. We recommend that users unmerge VMware Player:

 # emerge --unmerge "app-emulation/vmware-player"
 

NOTE: Users could upgrade to “>=app-emulation/vmware-player-3.1.5”, however these packages are not currently stable.

Gentoo discontinued support for VMware Workstation. We recommend that users unmerge VMware Workstation:

 # emerge --unmerge "app-emulation/vmware-workstation"
 

NOTE: Users could upgrade to “>=app-emulation/vmware-workstation-7.1.5”, however these packages are not currently stable.

Gentoo discontinued support for VMware Server. We recommend that users unmerge VMware Server:

 # emerge --unmerge "app-emulation/vmware-server"
 

References

Release Date
September 29, 2012

Latest Revision
September 29, 2012: 2

Severity
high

Exploitable
local, remote

Bugzilla entries