Multiple vulnerabilities have been found in Wireshark, allowing remote attackers to execute arbitrary code or cause Denial of Service.
|Package||net-analyzer/wireshark on all architectures|
|Affected versions||< 1.10.1|
|Unaffected versions||>= 1.10.1
revision >= 1.8.9
Wireshark is a versatile network protocol analyzer.
Multiple vulnerabilities have been discovered in Wireshark. Please review the CVE identifiers referenced below for details.
A remote attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
There is no known workaround at this time.
All Wireshark 1.10 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.10.1"
All Wireshark 1.8 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.8.9"