strongSwan: Multiple vulnerabilities — GLSA 201309-02

Multiple vulnerabilities have been found in strongSwan, possibly allowing remote attackers to authenticate as other users or cause a Denial of Service condition.

Affected Packages

net-misc/strongswan on all architectures
Affected versions < 5.1.0
Unaffected versions >= 5.1.0

Background

strongSwan is an IPSec implementation for Linux.

Description

Multiple vulnerabilities have been discovered in strongSwan. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could use ECDSA to authenticate as another user with an invalid signature. Additionally, a remote attacker could send a specially crafted request, possibly resulting in a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All strongSwan users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/strongswan-5.1.0"
 

References

Release Date
September 01, 2013

Latest Revision
September 01, 2013: 1

Severity
low

Exploitable
remote

Bugzilla entries