FileZilla: Multiple vulnerabilities — GLSA 201309-08

Multiple vulnerabilities have been found in FileZilla, the worst of which could result in arbitrary code execution.

Affected Packages

net-ftp/filezilla on all architectures
Affected versions < 3.7.3
Unaffected versions >= 3.7.3

Background

FileZilla is an open source FTP client.

Description

Multiple vulnerabilities have been discovered in FileZilla. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to connect to a malicious server, resulting in possible arbitrary code execution or a Denial of Service. Additionally, a local attacker could read sensitive memory, potentially resulting in password disclosure.

Workaround

There is no known workaround at this time.

Resolution

All FileZilla users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-ftp/filezilla-3.7.3"
 

References

Release Date
September 15, 2013

Latest Revision
September 15, 2013: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries