LibRaw, libkdcraw: Multiple vulnerabilities — GLSA 201309-09

Multiple vulnerabilities have been found in LibRaw and libkdcraw, the worst of which may lead to arbitrary code execution.

Affected Packages

media-libs/libraw on all architectures
Affected versions < 0.15.4
Unaffected versions >= 0.15.4
kde-base/libkdcraw on all architectures
Affected versions < 4.10.5-r1
Unaffected versions >= 4.10.5-r1

Background

LibRaw is a library for reading RAW files obtained from digital photo cameras. libkdcraw is a wrapper for LibRaw within KDE.

Description

Multiple vulnerabilities have been discovered in LibRaw and libkdcraw. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted file, possibly resulting in arbitrary code execution or Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All LibRaw users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/libraw-0.15.4"
 

All libkdcraw users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=kde-base/libkdcraw-4.10.5-r1"
 

References

Release Date
September 15, 2013

Latest Revision
September 15, 2013: 1

Severity
normal

Exploitable
remote

Bugzilla entries