Mozilla Products: Multiple vulnerabilities — GLSA 201309-23

Multiple vulnerabilities have been found in Mozilla Firefox, Thunderbird, and SeaMonkey, some of which may allow a remote user to execute arbitrary code.

Affected Packages

mail-client/thunderbird on all architectures
Affected versions < 17.0.9
Unaffected versions >= 17.0.9
www-client/firefox on all architectures
Affected versions < 17.0.9
Unaffected versions >= 17.0.9
www-client/seamonkey on all architectures
Affected versions < 2.21
Unaffected versions >= 2.21
mail-client/thunderbird-bin on all architectures
Affected versions < 17.0.9
Unaffected versions >= 17.0.9
www-client/firefox-bin on all architectures
Affected versions < 17.0.9
Unaffected versions >= 17.0.9
www-client/seamonkey-bin on all architectures
Affected versions < 2.21
Unaffected versions >= 2.21

Background

Mozilla Firefox is an open-source web browser and Mozilla Thunderbird an open-source email client, both from the Mozilla Project. The SeaMonkey project is a community effort to deliver production-quality releases of code derived from the application formerly known as the ‘Mozilla Application Suite’.

Description

Multiple vulnerabilities have been discovered in Mozilla Firefox, Thunderbird, and SeaMonkey. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to view a specially crafted web page or email, possibly resulting in execution of arbitrary code or a Denial of Service condition. Further, a remote attacker could conduct XSS attacks, spoof URLs, bypass address space layout randomization, conduct clickjacking attacks, obtain potentially sensitive information, bypass access restrictions, modify the local filesystem, or conduct other unspecified attacks.

Workaround

There is no known workaround at this time.

Resolution

All Mozilla Firefox users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/firefox-17.0.9"
 

All users of the Mozilla Firefox binary package should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/firefox-bin-17.0.9"
 

All Mozilla Thunderbird users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-client/thunderbird-17.0.9"
 

All users of the Mozilla Thunderbird binary package should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=mail-client/thunderbird-bin-17.0.9"
 

All SeaMonkey users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/seamonkey-2.21"
 

All users of the Mozilla SeaMonkey binary package should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/seamonkey-bin-2.21"
 

References

Release Date
September 27, 2013

Latest Revision
September 27, 2013: 1

Severity
high

Exploitable
remote

Bugzilla entries