Aircrack-ng: User-assisted execution of arbitrary code — GLSA 201310-06

A buffer overflow vulnerability in Aircrack-ng could result in execution of arbitrary code or Denial of Service.

Affected Packages

net-wireless/aircrack-ng on all architectures
Affected versions < 1.1-r2
Unaffected versions >= 1.1-r2

Background

Aircrack-ng is an 802.11 WEP and WPA-PSK keys cracking program that can recover keys once enough data packets have been captured.

Description

A buffer overflow vulnerability has been discovered in Aircrack-ng.

Impact

A remote attacker could entice a user to open a specially crafted dump file using Aircrack-ng, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Aircrack-ng users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-wireless/aircrack-ng-1.1-r2"
 

References

Release Date
October 07, 2013

Latest Revision
October 07, 2013: 1

Severity
normal

Exploitable
remote

Bugzilla entries