Setuptools: Man-in-the-Middle attack — GLSA 201310-09

A vulnerability in Setuptools could allow remote attackers to perform man-in-the-middle attacks.

Affected Packages

dev-python/setuptools on all architectures
Affected versions < 0.8-r1
Unaffected versions >= 0.8-r1

Background

Setuptools is a manager for Python packages.

Description

Setuptools does not check the integrity of downloaded Python packages.

Impact

A remote attacker could perform man-in-the-middle attacks to execute arbitrary code with the privileges of the process.

Workaround

There is no known workaround at this time.

Resolution

All Setuptools users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/setuptools-0.8-r1"
 

References

Release Date
October 10, 2013

Latest Revision
October 10, 2013: 1

Severity
normal

Exploitable
remote

Bugzilla entries