MPlayer: Multiple vulnerabilities — GLSA 201310-13

Multiple vulnerabilities have been found in MPlayer and the bundled FFmpeg, the worst of which may lead to the execution of arbitrary code.

Affected Packages

media-video/mplayer on all architectures
Affected versions < 1.1-r1
Unaffected versions >= 1.1-r1

Background

MPlayer is a media player including support for a wide range of audio and video formats.

Description

Multiple vulnerabilities have been discovered in MPlayer and the bundled FFmpeg. Please review the CVE identifiers and FFmpeg GLSA referenced below for details.

Impact

A remote attacker could entice a user to open a crafted media file to execute arbitrary code or cause a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All MPlayer users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-video/mplayer-1.1-r1"
 

References

Release Date
October 25, 2013

Latest Revision
October 25, 2013: 1

Severity
normal

Exploitable
remote

Bugzilla entries