GnuTLS: Multiple vulnerabilities — GLSA 201310-18

Multiple vulnerabilities have been discovered in GnuTLS, the worst of which could lead to Denial of Service.

Affected Packages

net-libs/gnutls on all architectures
Affected versions < 2.12.23-r1
Unaffected versions >= 2.12.23-r1

Background

GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0 protocols.

Description

Multiple vulnerabilities have been discovered in GnuTLS. Please review the CVE identifiers and Lucky Thirteen research paper referenced below for details.

Impact

A remote attacker could sent a specially crafted packet to cause a Denial of Service condition. Additionally, a remote attacker could perform man-in-the-middle attacks to recover plaintext data.

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.12.23-r1"
 

References

Release Date
October 28, 2013

Latest Revision
October 28, 2013: 1

Severity
normal

Exploitable
remote

Bugzilla entries