Mednafen: Arbitrary code execution — GLSA 201311-01

An unspecified vulnerability in Mednafen could result in the execution of arbitrary code.

Affected Packages

games-emulation/mednafen on all architectures
Affected versions < 0.8.13
Unaffected versions >= 0.8.13

Background

Mednafen is an advanced NES, GB/GBC/GBA, TurboGrafx 16/CD, NGPC and Lynx emulator.

Description

An unspecified vulnerability has been discovered in Mednafen when using network play.

Impact

A remote server could execute arbitrary code with the privileges of the process.

Workaround

There is no known workaround at this time.

Resolution

All Mednafen users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=games-emulation/mednafen-0.8.13"
 

References

Release Date
November 04, 2013

Latest Revision
November 04, 2013: 1

Severity
normal

Exploitable
remote

Bugzilla entries