Quassel: Multiple Vulnerabilities — GLSA 201311-03

Two vulnerabilities in Quassel may result in Denial of Service or SQL injection.

Affected Packages

net-irc/quassel on all architectures
Affected versions < 0.9.1
Unaffected versions >= 0.9.1

Background

Quassel is a Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity.

Description

Two vulnerabilities have been found in Quassel:

  • Quassel does not properly handle multiple CTCP requests (CVE-2010-3443).
  • Quassel, when used with certain versions of Qt and PostgreSQL, does not sanitize user input (CVE-2013-4422).

Impact

A remote attacker could send multiple CTCP requests in single private message, possibly resulting in a Denial of Service condition. Futhermore, a remote attacker may be able to execute arbitrary SQL statements.

Workaround

There is no known workaround at this time.

Resolution

All Quassel users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-irc/quassel-0.9.1"
 

References

Release Date
November 07, 2013

Latest Revision
November 07, 2013: 1

Severity
normal

Exploitable
remote

Bugzilla entries