cabextract: Multiple vulnerabilities — GLSA 201312-09

Multiple vulnerabilities have been found in cabextract, allowing remote attackers to execute arbitrary code or cause a Denial of Service condition.

Affected Packages

app-arch/cabextract on all architectures
Affected versions < 1.3
Unaffected versions >= 1.3

Background

cabextract is free software for extracting Microsoft cabinet files.

Description

Multiple vulnerabilities have been discovered in cabextract. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially-crafted archive in a .cab file, related to the libmspack library, potentially resulting in arbitrary code execution or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All cabextract users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-arch/cabextract-1.3"
 

NOTE: This is a legacy GLSA. Updates for all affected architectures are available since August 03, 2010. It is likely that your system is already no longer affected by this issue.

References

Release Date
December 14, 2013

Latest Revision
December 14, 2013: 1

Severity
normal

Exploitable
remote

Bugzilla entries