Wireshark: Multiple vulnerabilities — GLSA 201312-13

Multiple vulnerabilities have been found in Wireshark, allowing remote attackers to execute arbitrary code or cause Denial of Service.

Affected Packages

net-analyzer/wireshark on all architectures
Affected versions < 1.10.3
Unaffected versions >= 1.10.3, revision >= 1.8.11

Background

Wireshark is a versatile network protocol analyzer.

Description

Multiple vulnerabilities have been discovered in Wireshark. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Wireshark 1.10 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.10.3"
 

All Wireshark 1.8 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.8.11"
 

References

Release Date
December 16, 2013

Latest Revision
December 16, 2013: 1

Severity
normal

Exploitable
remote

Bugzilla entries