Tinyproxy: Denial of Service — GLSA 201312-15

A vulnerability has been found in Tinyproxy, allows remote attackers to cause a Denial of Service condition.

Affected Packages

net-proxy/tinyproxy on all architectures
Affected versions < 1.8.3-r3
Unaffected versions >= 1.8.3-r3

Background

Tinyproxy is a light-weight HTTP/HTTPS proxy daemon for POSIX operating systems.

Description

A vulnerability has been discovered in the way how Tinyproxy works with headers.

Impact

A remote attacker could send a specially crafted request with too many headers, possibly resulting in a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Tinyproxy users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-proxy/tinyproxy-1.8.3-r3"
 

References

Release Date
December 23, 2013

Latest Revision
December 23, 2013: 1

Severity
normal

Exploitable
remote

Bugzilla entries