Python: Multiple vulnerabilities — GLSA 201401-04

Multiple vulnerabilities have been found in Python, the worst of which allow remote attackers to cause a Denial of Service condition.

Affected Packages

dev-lang/python on all architectures
Affected versions < 3.3.2-r1
Unaffected versions revision >= 3.2.5-r1
revision >= 2.6.8
revision >= 2.7.3-r1
>= 3.3.2-r1
revision >= 2.6.9
revision >= 2.7.4
revision >= 2.7.5
revision >= 2.7.6
revision >= 2.7.7
revision >= 2.7.8
revision >= 2.7.9
revision >= 2.7.10
revision >= 2.7.11
revision >= 2.7.12
revision >= 2.7.13
revision >= 2.7.14
revision >= 2.7.15

Background

Python is an interpreted, interactive, object-oriented programming language.

Description

Multiple vulnerabilities have been discovered in Python. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly cause a Denial of Service condition or perform a man-in-the-middle attack to disclose sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All Python 3.3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/python-3.3.2-r1"
 

All Python 3.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/python-3.2.5-r1"
 

All Python 2.6 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/python-2.6.8"
 

All Python 2.7 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/python-2.7.3-r1"
 

References

Release Date
January 06, 2014

Latest Revision
June 17, 2015: 5

Severity
normal

Exploitable
remote

Bugzilla entries