libexif, exif: Multiple vulnerabilities — GLSA 201401-10

Multiple vulnerabilities have been found in libexif and exif, some of which may allow execution of arbitrary code.

Affected Packages

media-libs/libexif on all architectures
Affected versions < 0.6.21
Unaffected versions >= 0.6.21
media-gfx/exif on all architectures
Affected versions < 0.6.21
Unaffected versions >= 0.6.21

Background

libexif is a library for parsing, editing and saving Exif metadata from images. exif is a small command line interface for libexif.

Description

Multiple vulnerabilities have been discovered in libexif and exif. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted image file using exif or an application linked against libexif, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All libexif users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/libexif-0.6.21"
 

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

All exif users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-gfx/exif-0.6.21"
 

References

Release Date
January 19, 2014

Latest Revision
January 19, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries