Apache mod_fcgid: Arbitrary code execution — GLSA 201402-09

A buffer overflow in Apache mod_fcgid might allow remote attackers to execute arbitrary code or cause a Denial of Service condition.

Affected Packages

www-apache/mod_fcgid on all architectures
Affected versions < 2.3.9
Unaffected versions >= 2.3.9

Background

Apache mod_fcgid is a binary-compatible alternative to mod_fastcgi with better process management.

Description

Apache mod_fcgid fails to perform a boundary check on user-supplied input, potentially resulting in a heap-based buffer overflow.

Impact

A remote attacker can supply a crafted input, possibly resulting in execution of arbitrary code or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Apache mod_fcgid users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apache/mod_fcgid-2.3.9"
 

References

Release Date
February 07, 2014

Latest Revision
February 07, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries