PulseAudio: Insecure temporary file usage — GLSA 201402-10

An insecure temporary file usage has been reported in PulseAudio, possibly allowing symlink attacks.

Affected Packages

media-sound/pulseaudio on all architectures
Affected versions < 0.9.22
Unaffected versions >= 0.9.22

Background

PulseAudio is a sound system for POSIX OSes.

Description

The pa_make_secure_dir function in core-util.c does not handle temporary files securely.

Impact

A local attacker could perform symlink attacks to overwrite arbitrary files with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All PulseAudio users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-sound/pulseaudio-0.9.22"
 

References

Release Date
February 07, 2014

Latest Revision
February 07, 2014: 1

Severity
normal

Exploitable
local

Bugzilla entries