PAM S/Key: Information disclosure — GLSA 201402-12

PAM S/Key does not clear provided credentials from memory, allowing local attackers to gain access to cleartext credentials.

Affected Packages

sys-auth/pam_skey on all architectures
Affected versions < 1.1.5-r5
Unaffected versions >= 1.1.5-r5

Background

PAM S/Key is a pluggable authentication module for the OpenBSD Single-key Password system.

Description

Ulrich Müller reported that a Gentoo patch to PAM S/Key does not remove credentials provided by the user from memory.

Impact

A local attacker with privileged access could inspect a memory dump to gain access to cleartext credentials provided by users.

Workaround

There is no known workaround at this time.

Resolution

All PAM S/Key users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-auth/pam_skey-1.1.5-r5"
 

References

Release Date
February 09, 2014

Latest Revision
February 09, 2014: 1

Severity
normal

Exploitable
local

Bugzilla entries