QtCore: Denial of Service — GLSA 201403-04

A vulnerability in QXmlSimpleReader class can be used to cause a Denial of Service condition.

Affected Packages

dev-qt/qtcore on all architectures
Affected versions < 4.8.5-r1
Unaffected versions >= 4.8.5-r1

Background

The Qt toolkit is a comprehensive C++ application development framework.

Description

A vulnerability in QXmlSimpleReader’s XML entity parsing has been discovered.

Impact

A remote attacker could entice a user to open a specially crafted XML file using an application linked against QtCore, possibly resulting in Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All QtCore users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-qt/qtcore-4.8.5-r1"
 

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying these packages.

References

Release Date
March 13, 2014

Latest Revision
March 13, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries