GNU Emacs: Multiple vulnerabilities — GLSA 201403-05

Two vulnerabilities have been found in GNU Emacs, possibly leading to user-assisted execution of arbitrary code.

Affected Packages

app-editors/emacs on all architectures
Affected versions < 24.1-r1
Unaffected versions >= 24.1-r1
revision >= 23.4-r4
< 23.2

Background

GNU Emacs is a highly extensible and customizable text editor.

Description

Multiple vulnerabilities have been discovered in GNU Emacs:

  • When ‘global-ede-mode’ is enabled, EDE in Emacs automatically loads a Project.ede file from the project directory (CVE-2012-0035).
  • When ‘enable-local-variables’’ is set to ‘:safe’, Emacs automatically processes eval forms (CVE-2012-3479).

Impact

A remote attacker could entice a user to open a specially crafted file, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All GNU Emacs 24.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-editors/emacs-24.1-r1"
 

All GNU Emacs 23.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-editors/emacs-23.4-r4"
 

References

Release Date
March 20, 2014

Latest Revision
March 20, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries