Multiple vulnerabilities have been found in Adobe Flash Player, the worst of which could result in execution of arbitrary code.
|Package||www-plugins/adobe-flash on all architectures|
|Affected versions||< 18.104.22.1686|
|Unaffected versions||>= 22.214.171.1246|
The Adobe Flash Player is a renderer for the SWF file format, which is commonly used to provide interactive websites.
Multiple vulnerabilities have been discovered in Adobe Flash Player. Please review the CVE identifiers referenced below for details.
A remote attacker could entice a user to open a specially crafted SWF file using Adobe Flash Player, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition. Furthermore, a remote attacker may be able to bypass the Same Origin Policy or read the clipboard via unspecified vectors.
There is no known workaround at this time.
All Adobe Flash Player users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-plugins/adobe-flash-126.96.36.1996"