Asterisk: Denial of Service — GLSA 201405-05

Multiple buffer overflows in Asterisk might allow remote attackers to cause a Denial of Service condition.

Affected Packages

net-misc/asterisk on all architectures
Affected versions < 11.8.1
Unaffected versions >= 11.8.1, revision >= 1.8.26.1

Background

Asterisk is an open source telephony engine and toolkit.

Description

Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers and Asterisk Project Security Advisories referenced below for details.

Impact

A remote attacker could possibly cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Asterisk 11.* users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/asterisk-11.8.1"
 

All Asterisk 1.8.* users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.26.1"
 

References

Release Date
May 03, 2014

Latest Revision
May 03, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries