Multiple vulnerabilities have been discovered in ImageMagick, the worst of which could lead to arbitrary code execution.
|Package||media-gfx/imagemagick on all architectures|
|Affected versions||< 18.104.22.168|
|Unaffected versions||>= 22.214.171.124|
ImageMagick is a collection of tools and libraries for manipulating various image formats.
Multiple vulnerabilities have been discovered in ImageMagick. Please review the CVE identifiers referenced below for details.
Note that CVE-2012-1185 and CVE-2012-1186 were issued due to incomplete fixes for CVE-2012-0247 and CVE-2012-0248, respectively. The earlier CVEs were addressed in GLSA 201203-09.
A remote attacker can utilize multiple vectors to execute arbitrary code or cause a Denial of Service condition.
There is no known workaround at this time.
All ImageMagick users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-gfx/imagemagick-126.96.36.199"