JBIG-KIT: Denial of Service — GLSA 201405-20

A stack-based buffer overflow in JBIG-KIT might allow remote attackers to cause a Denial of Service.

Affected Packages

media-libs/jbigkit on all architectures
Affected versions < 2.1
Unaffected versions >= 2.1

Background

JBIG-KIT is a software implementation of the JBIG1 data compression standard.

Description

JBIG-KIT contains a stack-based buffer overflow in the jbg_dec_in function in libjbig/jbig.c.

Impact

A remote attacker could possibly cause a Denial of Service condition via a specially crafted image file.

Workaround

There is no known workaround at this time.

Resolution

All JBIG-KIT users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/jbigkit-2.1"
 

References

Release Date
May 18, 2014

Latest Revision
May 18, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries