A vulnerability in lib3ds might allow a remote attacker to execute arbitrary code.
|Package||media-libs/lib3ds on all architectures|
|Affected versions||< 2.0.0_rc1|
|Unaffected versions||>= 2.0.0_rc1, revision >= 1.3.0-r1|
lib3ds is a library for managing 3D-Studio Release 3 and 4 .3DS files.
An array index error has been discovered in lib3ds.
A remote attacker could entice a user to open a specially crafted 3DS file using an application linked against lib3ds, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
There is no known workaround at this time.
All lib3ds 2.0 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/lib3ds-2.0.0_rc1"
All lib3ds 1.3 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/lib3ds-1.3.0-r1"
Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.