lib3ds: User-assisted execution of arbitrary code — GLSA 201405-23

A vulnerability in lib3ds might allow a remote attacker to execute arbitrary code.

Affected Packages

media-libs/lib3ds on all architectures
Affected versions < 2.0.0_rc1
Unaffected versions >= 2.0.0_rc1, revision >= 1.3.0-r1

Background

lib3ds is a library for managing 3D-Studio Release 3 and 4 .3DS files.

Description

An array index error has been discovered in lib3ds.

Impact

A remote attacker could entice a user to open a specially crafted 3DS file using an application linked against lib3ds, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All lib3ds 2.0 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/lib3ds-2.0.0_rc1"
 

All lib3ds 1.3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/lib3ds-1.3.0-r1"
 

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

References

Release Date
May 18, 2014

Latest Revision
December 10, 2014: 2

Severity
normal

Exploitable
remote

Bugzilla entries