SystemTap: Denial of Service — GLSA 201406-04

A vulnerability in SystemTap could allow a local attacker to create a Denial of Service condition.

Affected Packages

dev-util/systemtap on all architectures
Affected versions < 2.0
Unaffected versions >= 2.0

Background

SystemTap is a kernel profiling and instrumentation tool.

Description

SystemTap does not properly handle DWARF expressions when unwinding the stack.

Impact

A local attacker with SystemTap permissions could trigger a kernel panic, causing a Denial of Service condition.

Workaround

Disabling unprivileged mode is a temporary workaround for this vulnerability.

Resolution

All SystemTap users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-util/systemtap-2.0"
 

References

Release Date
June 05, 2014

Latest Revision
June 05, 2014: 1

Severity
normal

Exploitable
local

Bugzilla entries