GnuTLS: Multiple vulnerabilities — GLSA 201406-09

Multiple vulnerabilities have been discovered in GnuTLS, the worst of which could lead to arbitrary code execution.

Affected Packages

net-libs/gnutls on all architectures
Affected versions < 2.12.23-r6
Unaffected versions >= 2.12.23-r6

Background

GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0 protocols.

Description

Multiple vulnerabilities have been discovered in GnuTLS. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could utilize multiple vectors to spoof arbitrary SSL servers via a crafted certificate, execute arbitrary code or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.12.23-r6"
 

References

Release Date
June 13, 2014

Latest Revision
June 13, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries