FreeRADIUS: Arbitrary code execution — GLSA 201406-12

A vulnerability in FreeRADIUS can lead to arbitrary code execution or Denial of Service by authenticated users.

Affected Packages

net-dialup/freeradius on all architectures
Affected versions < 2.2.5
Unaffected versions >= 2.2.5

Background

FreeRADIUS is an open source RADIUS authentication server.

Description

Large passwords can trigger a stack-based buffer overflow in FreeRADIUS’s rlm_pap module when authenticating against an LDAP server.

Impact

An authenticated user could set a specially crafted long password, possibly leading to arbitrary code execution or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All FreeRADIUS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-dialup/freeradius-2.2.5"
 

References

Release Date
June 15, 2014

Latest Revision
June 15, 2014: 1

Severity
high

Exploitable
remote

Bugzilla entries