memcached: Multiple vulnerabilities — GLSA 201406-13

Multiple vulnerabilities have been found in memcached, allowing remote attackers to execute arbitrary code or cause Denial of Service.

Affected Packages

net-misc/memcached on all architectures
Affected versions < 1.4.17
Unaffected versions >= 1.4.17

Background

memcached is a high-performance, distributed memory object caching system

Description

memcached authentication could be bypassed when using SASL due to a flaw related to SASL authentication state. Also several heap-based buffer overflows due to integer conversions when parsing certain length attributes were discovered.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, cause a Denial of Service condition or authenticate with invalid SASL credentials, bypassing memcached authentication completely.

Workaround

There is no known workaround at this time.

Resolution

All memcached users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/memcached-1.4.17"
 

References

Release Date
June 15, 2014

Latest Revision
June 15, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries