cups-filters: Multiple vulnerabilities — GLSA 201406-16

Multiple vulnerabilities have been found in cups-filters, worst of which allows remote attackers to execute arbitrary code.

Affected Packages

net-print/cups-filters on all architectures
Affected versions < 1.0.53
Unaffected versions >= 1.0.53

Background

cups-filters is an OpenPrinting CUPS Filters.

Description

Multiple vulnerabilities have been discovered in cups-filters. Please review the CVE identifiers referenced below for more details about the vulnerabilities.

Impact

A remote attacker(s) could possibly execute arbitrary code utilizing multiple attack vectors, or a local attacker could gain escalated privileges via a specially crafted shared library.

Workaround

There is no known workaround at this time.

Resolution

All cups-filters users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-print/cups-filters-1.0.53"
 

References

Release Date
June 16, 2014

Latest Revision
June 16, 2014: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries