Asterisk: Multiple vulnerabilities — GLSA 201406-25

Multiple vulnerabilities have been discovered in Asterisk, the worst of which could allow privileged users to execute arbitrary system shell commands.

Affected Packages

net-misc/asterisk on all architectures
Affected versions < 11.10.2
Unaffected versions >= 11.10.2, revision >= 1.8.28.2

Background

Asterisk is an open source telephony engine and toolkit.

Description

Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers below for details.

Impact

A remote attacker that gains access to a privileged Asterisk account can execute arbitrary system shell commands. Furthermore an unprivileged remote attacker could cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Asterisk 11 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/asterisk-11.10.2"
 

All Asterisk 1.8 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.28.2"
 

References

Release Date
June 25, 2014

Latest Revision
June 25, 2014: 2

Severity
normal

Exploitable
remote

Bugzilla entries