Multiple vulnerabilities have been discovered in Asterisk, the worst of which could allow privileged users to execute arbitrary system shell commands.
|Package||net-misc/asterisk on all architectures|
|Affected versions||< 11.10.2|
|Unaffected versions||>= 11.10.2, revision >= 220.127.116.11|
Asterisk is an open source telephony engine and toolkit.
Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers below for details.
A remote attacker that gains access to a privileged Asterisk account can execute arbitrary system shell commands. Furthermore an unprivileged remote attacker could cause a Denial of Service condition.
There is no known workaround at this time.
All Asterisk 11 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-misc/asterisk-11.10.2"
All Asterisk 1.8 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-misc/asterisk-18.104.22.168"
June 25, 2014
June 25, 2014: 2