Django: Multiple vulnerabilities — GLSA 201406-26

Multiple vulnerabilities have been found Django, the worst of which may allow a remote attacker to execute code.

Affected Packages

dev-python/django on all architectures
Affected versions < 1.6.5
Unaffected versions >= 1.6.5, revision >= 1.5.8, revision >= 1.4.13, revision >= 1.5.10, revision >= 1.4.15

Background

Django is a Python-based web framework.

Description

Multiple vulnerabilities have been discovered in Django. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could execute code with the privileges of the process, modify SQL queries, or disclose sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All Django 1.6 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/django-1.6.5"
 

All Django 1.5 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/django-1.5.8"
 

All Django 1.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/django-1.4.13"
 

References

Release Date
June 26, 2014

Latest Revision
December 03, 2014: 2

Severity
normal

Exploitable
remote

Bugzilla entries