Wireshark: Multiple vulnerabilities — GLSA 201406-33

Multiple vulnerabilities have been found in Wireshark, the worst of which allows remote attackers to execute arbitrary code.

Affected Packages

net-analyzer/wireshark on all architectures
Affected versions < 1.10.8
Unaffected versions revision >= 1.8.15, >= 1.10.8

Background

Wireshark is a network protocol analyzer formerly known as ethereal.

Description

Multiple vulnerabilities have been discovered in Wireshark. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker can cause arbitrary code execution or a Denial of Service condition via a specially crafted packet.

Workaround

There is no known workaround at this time.

Resolution

All Wireshark 1.8.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.8.15"
 

All Wireshark 1.10.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.10.8"
 

References

Release Date
June 29, 2014

Latest Revision
June 29, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries