Multiple vulnerabilities have been found in Wireshark, the worst of which allows remote attackers to execute arbitrary code.
|Package||net-analyzer/wireshark on all architectures|
|Affected versions||< 1.10.8|
|Unaffected versions||revision >= 1.8.15, >= 1.10.8|
Wireshark is a network protocol analyzer formerly known as ethereal.
Multiple vulnerabilities have been discovered in Wireshark. Please review the CVE identifiers referenced below for details.
A remote attacker can cause arbitrary code execution or a Denial of Service condition via a specially crafted packet.
There is no known workaround at this time.
All Wireshark 1.8.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.8.15"
All Wireshark 1.10.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.10.8"