OpenTTD: Denial of Service — GLSA 201407-01

A vulnerability in OpenTTD could allow a remote attacker to cause a Denial of Service condition.

Affected Packages

games-simulation/openttd on all architectures
Affected versions < 1.3.3
Unaffected versions >= 1.3.3

Background

OpenTTD is a clone of Transport Tycoon Deluxe.

Description

The vulnerability is caused due to missing out-of-bound check within the “HandleCrashedAircraft()” function.

Impact

A remote attacker could possibly cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All OpenTTD users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=games-simulation/openttd-1.3.3"
 

References

Release Date
July 07, 2014

Latest Revision
July 07, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries