ModPlug XMMS Plugin: Multiple vulnerabilities — GLSA 201408-07

Multiple vulnerabilities have been found in ModPlug XMMS Plugin, worst of which allows remote attackers to execute arbitrary code.

Affected Packages

media-libs/libmodplug on all architectures
Affected versions < 0.8.8.5
Unaffected versions >= 0.8.8.5

Background

ModPlug XMMS Plugin is a library for playing MOD-like music files

Description

Multiple vulnerabilities have been discovered in ModPlug XMMS Plugin. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All ModPlug XMMS Plugin users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/libmodplug-0.8.8.5"
 

References

Release Date
August 16, 2014

Latest Revision
August 16, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries