Multiple vulnerabilities have been discovered in PHP, the worst of which could lead to remote execution of arbitrary code.
|Package||dev-lang/php on all architectures|
|Affected versions||< 5.5.16|
|Unaffected versions||>= 5.5.16, revision >= 5.4.32, revision >= 5.3.29, revision >= 5.4.34, revision >= 5.4.35, revision >= 5.4.36, revision >= 5.4.37, revision >= 5.4.38, revision >= 5.4.39, revision >= 5.4.40, revision >= 5.4.41, revision >= 5.4.42, revision >= 5.4.43, revision >= 5.4.44, revision >= 5.4.45, revision >= 5.4.46|
PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.
Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.
A context-dependent attacker can cause arbitrary code execution, create a Denial of Service condition, read or write arbitrary files, impersonate other servers, hijack a web session, or have other unspecified impact. Additionally, a local attacker could gain escalated privileges.
There is no known workaround at this time.
All PHP 5.5 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-5.5.16"
All PHP 5.4 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-5.4.32"
All PHP 5.3 users should upgrade to the latest version. This release marks the end of life of the PHP 5.3 series. Future releases of this series are not planned. All PHP 5.3 users are encouraged to upgrade to the current stable version of PHP 5.5 or previous stable version of PHP 5.4, which are supported till at least 2016 and 2015 respectively.
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-5.3.29"