PostgreSQL: Multiple vulnerabilities — GLSA 201408-15

Multiple vulnerabilities have been found in PostgreSQL, the worst of which may allow remote Denial of Service.

Affected Packages

dev-db/postgresql-server on all architectures
Affected versions < 9.3.3
Unaffected versions >= 9.3.3, revision >= 9.2.7, revision >= 9.1.12, revision >= 9.0.16, revision >= 8.4.20

Background

PostgreSQL is an open source object-relational database management system.

Description

Multiple vulnerabilities have been discovered in PostgreSQL. Please review the CVE identifiers referenced below for details.

Impact

A remote authenticated attacker may be able to create a Denial of Service condition, bypass security restrictions, or have other unspecified impact.

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL 9.3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.3.3"
 

All PostgreSQL 9.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.2.7"
 

All PostgreSQL 9.1 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.1.12"
 

All PostgreSQL 9.0 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.0.16"
 

All PostgreSQL 8.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-8.4.20"
 

References

Release Date
August 29, 2014

Latest Revision
August 29, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries