NRPE: Multiple Vulnerabilities — GLSA 201408-18

Multiple vulnerabilities have been found in NRPE, the worst of which can allow execution of arbitrary code.

Affected Packages

net-analyzer/nrpe on all architectures
Affected versions < 2.15
Unaffected versions >= 2.15

Background

Nagios Remote Plugin Executor (NRPE) remotely executes Nagios plugins on other Linux/Unix machines.

Description

Multiple vulnerabilities have been discovered in NRPE. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker can utilize multiple vectors to execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All NRPE users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-analyzer/nrpe-2.15"
 

References

Release Date
August 30, 2014

Latest Revision
August 30, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries