Bash: Multiple vulnerabilities — GLSA 201410-01

Multiple parsing flaws in Bash could allow remote attackers to inject code or cause a Denial of Service condition.

Affected Packages

app-shells/bash on all architectures
Affected versions < 4.2_p52
Unaffected versions revision >= 3.1_p22, revision >= 3.2_p56, revision >= 4.0_p43, revision >= 4.1_p16, >= 4.2_p52

Background

Bash is the standard GNU Bourne Again SHell.

Description

Florian Weimer, Todd Sabin, Michal Zalewski et al. discovered further parsing flaws in Bash. The unaffected Gentoo packages listed in this GLSA contain the official patches to fix the issues tracked as CVE-2014-6277, CVE-2014-7186, and CVE-2014-7187. Furthermore, the official patch known as “function prefix patch” is included which prevents the exploitation of CVE-2014-6278.

Impact

A remote attacker could exploit these vulnerabilities to execute arbitrary commands or cause a Denial of Service condition via various vectors.

Workaround

There is no known workaround at this time.

Resolution

All Bash 3.1 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-shells/bash-3.1_p22:3.1"
 

All Bash 3.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-shells/bash-3.2_p56:3.2"
 

All Bash 4.0 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-shells/bash-4.0_p43:4.0"
 

All Bash 4.1 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-shells/bash-4.1_p16:4.1"
 

All Bash 4.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-shells/bash-4.2_p52"
 

References

Release Date
October 04, 2014

Latest Revision
October 04, 2014: 1

Severity
high

Exploitable
local, remote

Bugzilla entries