PHP: Multiple vulnerabilities — GLSA 201411-04

Multiple vulnerabilities have been discovered in PHP, the worst of which could lead to remote execution of arbitrary code.

Affected Packages

dev-lang/php on all architectures
Affected versions < 5.5.18
Unaffected versions >= 5.5.18
revision >= 5.4.34
revision >= 5.3.29
revision >= 5.4.36
revision >= 5.4.37
revision >= 5.4.38
revision >= 5.4.39
revision >= 5.4.35
revision >= 5.4.40
revision >= 5.4.41
revision >= 5.4.42
revision >= 5.4.43
revision >= 5.4.44
revision >= 5.4.45
revision >= 5.4.46

Background

PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.

Description

Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.

Impact

A context-dependent attacker can possibly execute arbitrary code or create a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All PHP 5.5 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-5.5.18"
 

All PHP 5.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-5.4.34"
 

All PHP 5.3 users should upgrade to the latest version. This release marks the end of life of the PHP 5.3 series. Future releases of this series are not planned. All PHP 5.3 users are encouraged to upgrade to the current stable version of PHP 5.5 or previous stable version of PHP 5.4, which are supported till at least 2016 and 2015 respectively.

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-5.3.29"
 

References

Release Date
November 09, 2014

Latest Revision
August 22, 2015: 3

Severity
normal

Exploitable
remote

Bugzilla entries