libvirt: Multiple vulnerabilities — GLSA 201412-04

Multiple vulnerabilities have been found in libvirt, worst of which allows context-dependent attackers to escalate privileges.

Affected Packages

app-emulation/libvirt on all architectures
Affected versions < 1.2.9-r2
Unaffected versions >= 1.2.9-r2

Background

libvirt is a C toolkit for manipulating virtual machines.

Description

Multiple vulnerabilities have been discovered in libvirt. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker may be able to cause a Denial of Service or cause information leakage. A local attacker may be able to escalate privileges, cause a Denial of Service or possibly execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All libvirt users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/libvirt-1.2.9-r2"
 

References

Release Date
December 08, 2014

Latest Revision
December 08, 2014: 1

Severity
high

Exploitable
local, remote

Bugzilla entries