Django: Multiple vulnerabilities — GLSA 201412-22

Multiple vulnerabilities have been found in Django, the worst of which may lead to Denial of Service.

Affected Packages

dev-python/django on all architectures
Affected versions < 1.6.7
Unaffected versions >= 1.6.7, revision >= 1.5.10, revision >= 1.4.15

Background

Django is a Python-based web framework.

Description

Multiple vulnerabilities have been discovered in Django. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker may be able to create a Denial of Service condition, obtain sensitive information, or hijack web sessions.

Workaround

There is no known workaround at this time.

Resolution

All Django 1.6 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/django-1.6.7"
 

All Django 1.5 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/django-1.5.10"
 

All Django 1.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/django-1.4.15"
 

References

Release Date
December 13, 2014

Latest Revision
December 13, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries