Multiple vulnerabilities have been found in Apache Tomcat, the worst of which may result in Denial of Service.
|Package||www-servers/tomcat on all architectures|
|Affected versions||< 7.0.56|
|Unaffected versions||>= 7.0.56
revision >= 6.0.41
revision >= 6.0.42
revision >= 6.0.43
revision >= 6.0.44
revision >= 6.0.45
revision >= 6.0.46
revision >= 6.0.47
revision >= 6.0.48
Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.
Multiple vulnerabilities have been discovered in Tomcat. Please review the CVE identifiers referenced below for details.
A remote attacker may be able to cause a Denial of Service condition as well as obtain sensitive information, bypass protection mechanisms and authentication restrictions.
There is no known workaround at this time.
All Tomcat 6.0.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-servers/tomcat-6.0.41"
All Tomcat 7.0.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-servers/tomcat-7.0.56"