MuPDF: User-assisted execution of arbitrary code — GLSA 201412-43

Multiple vulnerabilities have been found in MuPDF, possibly resulting in remote code execution or Denial of Service.

Affected Packages

app-text/mupdf on all architectures
Affected versions < 1.3_p20140118
Unaffected versions >= 1.3_p20140118

Background

MuPDF is a lightweight PDF viewer and toolkit written in portable C.

Description

Multiple vulnerabilities have been discovered in MuPDF. Please review the CVE identifier and Secunia Research referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted PDF using MuPDF, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All MuPDF users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/mupdf-1.3_p20140118"
 

References

Release Date
December 26, 2014

Latest Revision
December 26, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries